Некоторые технические проблемы

Тема в разделе "Технический раздел", создана пользователем Ivaemon, 27 ноя 2013.

  1. Ivaemon

    Ivaemon Хранитель

    Сообщения:
    1.107
    Вопрос возник такой. В настройках стоит разрешение всплывающего окна при личном сообщении. Но окно не всплывает. Настройки браузера не мешают (Хром), ABP на этом ресурсе отключен. Антивирус тоже не влияет. На других ресурсах окно появляется. В чем может быть загвоздка?
    Проблема в том, что в отсутствие окна других индикаторов получения новых сообщений дизайн сайта, похоже, не предусматривает. Возможно ли добавить какую-нибудь дополнительную индикацию, вроде (1) рядом с надписью "Личные сообщения", как это есть на некоторых форумах?
    И еще момент. При оценке форумчанами поста на почту автоматически приходит письмо. Можно как-нибудь это отключить? В настройках не нашел, где это указать.
    Заранее благодарен за помощь.
     
  2. Lotos

    Lotos Administrator ИО "Солнечный Ветер"

    Сообщения:
    1.571
    Странно... Протестировал - у меня всё работает. Также в оснвоных настройках выбрал "Разрешить уведомления о новых ЛС всплывающим окном":

    [​IMG]

    И вот результат:

    [​IMG]

    Может всё же дело в браузере? У меня тоже Хром. Стрелкой отметил ещё и индикатор, который сообщает о том, что есть новое сообщение (если не работает всплывающее окно). Там в уведомлениях сообщается о новых ЛС, новых публичных сообщениях, предложения дружбы, нажатия кнопки "спасибо" или других кнопок.

    Да, можно. В кабинете, в самом низу есть раздел "DBTech - Post Thanks", там нужно зайти в "Settings":

    [​IMG]

    и поставить галочку на "Disable Emails" :

    [​IMG]
     
  3. Ivaemon

    Ivaemon Хранитель

    Сообщения:
    1.107
    Lotos, спасибо. Значит, дело в браузере... Даже единичку не отображает. Все скрипты разрешены... ничего не понимаю.
    Ладно, посмотрим.
     
  4. Ivaemon

    Ivaemon Хранитель

    Сообщения:
    1.107
    А, нет, прошу прощения. Уведомления новые цифрами он показывает - те. которые на почту идут за посты. А как увидеть именно личные сообщения, если окно не всплывает?
     
  5. Lotos

    Lotos Administrator ИО "Солнечный Ветер"

    Сообщения:
    1.571
    Попробуй в других обозревателях: Opera, Internet Explorer, Mozilla Firefox. Там работает? Если и там нигде не работает, то ещё гляну настройки сайта, может что-то где-то влияет.
     
  6. Ivaemon

    Ivaemon Хранитель

    Сообщения:
    1.107
    Пардон, все правильно - в уведомлениях выплывает балун: "1 непрочитанное сообщение". Слава Богу, вопрос решен. А то я уже тут экспериментирую с Нортоном, отключил защиту браузера - все равно не всплывает.
     
  7. Lotos

    Lotos Administrator ИО "Солнечный Ветер"

    Сообщения:
    1.571
    Отлично! А я уже нарисовал какими способами можно попасть в личные сообщения))

    [​IMG]
     
  8. Ivaemon

    Ivaemon Хранитель

    Сообщения:
    1.107
    Сегодня наблюдается глюк с вставкой изображения. Появляется сдвоенное изображение: одно в тексте, на месте вставки, другое - после текста, как вложение. При удалении ссылки вложение остается, как это получилось, например, здесь: http://manvantara.info/showthread.php?t=1478&p=15716#post15716
    Как от этого избавиться?
     
  9. Lotos

    Lotos Administrator ИО "Солнечный Ветер"

    Сообщения:
    1.571
    Это не глюк. Нужно просто при загрузке иображения проконтролировать чтобы код загруженного вложения вставился в текст сообщения. Сначала выбрать вложение в окне загрузки вложений и нажать "Вставить в текст":

    [​IMG]

    И посмотреть появился ли код вложения:

    [​IMG]

    Исправил этот момент в тексте и теперь там всё нормально.
     
  10. Ivaemon

    Ivaemon Хранитель

    Сообщения:
    1.107
    Дело в том, что я не хотел загружать на сайт изображение, а хотел вставить ссылку на него, но по-ошибке загрузил (не снял галочку). После появления кода стер строку, но изображение не исчезло.
     
  11. Lotos

    Lotos Administrator ИО "Солнечный Ветер"

    Сообщения:
    1.571
    А, тогде да. Если просто удалить надпись, то вложение появится в конце сообщения в списке вложений. Нужно удалять и из панели загрузок вложений. А если просто стереть надпись и добавить изображение по внешней ссылке, то появится в сообщении два изображения. Поэтому нужно использовать либо один способ, либо второй. Но лучше конечно по внешней ссылке. Если только это не что-то особо ценное, что нужно сохранить локально на форуме.
     
  12. Ivaemon

    Ivaemon Хранитель

    Сообщения:
    1.107
    А как удалять из панели загрузок?
     
  13. Lotos

    Lotos Administrator ИО "Солнечный Ветер"

    Сообщения:
    1.571
    Если навести мышкой на загруженный файл, то там появится кнопка "Удалить":

    [​IMG]
     
  14. Ivaemon

    Ivaemon Хранитель

    Сообщения:
    1.107
    А как вообще выйти на эту панель загрузок?
     
  15. Lotos

    Lotos Administrator ИО "Солнечный Ветер"

    Сообщения:
    1.571
    В расширенном режиме написания сообщения есть дополнительные опции и там кнопка "Управление вложениями":

    [​IMG]

    Можно зайти и в кабинет. Там есть пункт меню "Вложения", где можно увидеть их спикок, где какое находится, отметить галочками ненужное и удалить:

    [​IMG]
     
  16. Ivaemon

    Ivaemon Хранитель

    Сообщения:
    1.107
    Да, с расширенным режимом понял, все получается.
    А вот из кабинета, из списка загруженных файлов, непонятно, как выделять и удалять...
     
  17. Lotos

    Lotos Administrator ИО "Солнечный Ветер"

    Сообщения:
    1.571
    Там внизу списка сначала для удобства желательно включить отображение миниатюр:

    [​IMG]

    Потом справа отметить галочками что на удаление и нажать "Удалить выделенные":

    [​IMG]
     
  18. Ivaemon

    Ivaemon Хранитель

    Сообщения:
    1.107
    Lotos, у меня не отображаются места для галочек:

    [​IMG]

    И внизу нет кнопки "Удалить выделенное".
     
  19. Lotos

    Lotos Administrator ИО "Солнечный Ветер"

    Сообщения:
    1.571
    Вот это странно. Проверил на тестовом пользователе, у которого стандартные права зарегистрированного пользователя - всё видно. Ещё и в разных браузерах перепроверил. Посмотрел ещё раз все настройки - не нашёл причины невидимости галочек и кнопки. Может дело в браузере, не знаю.
     
  20. Lotos

    Lotos Administrator ИО "Солнечный Ветер"

    Сообщения:
    1.571
    Аа, вообще-то есть одна идея. Может дело в истечении срока редактирования прошлых сообщений. А поскольку вложения привязываются к этим сообщениям, то и их нельзя удалять. Сейчас отменю временные ограничения и попробуйте снова посмотреть.